ℹ️[S3] ConnectWise Update from 2025-05-03 09:30 EDT to 2025-05-03 10:30 EDT

Scheduled maintenance Services Connectwise 📊 S3
2025-05-03 09:30 EDT · 1 hour

Updates

Resolved

This maintenance has been concluded as planned.

May 3, 2025 · 10:30 EDT
Started

This maintenance is now starting as planned.

May 3, 2025 · 09:30 EDT
Update

Please note that the following maintenance has been successfully completed.

May 3, 2025 · 09:07 EDT
Scheduled

We will perform the latest patches for our current version.
There will be intermittent service unavailability during maintenance.

May 2, 2025 · 09:46 EDT

← Back