[S3] NCentral update to 2024.6 - #3014340 from 2025-01-12 03:00 EST to 2025-01-12 06:00 EST

Scheduled maintenance Services N-central 📊 S3
2025-01-12 03:00 EST · 3 hours

Updates

Resolved

This maintenance has been concluded as planned.

January 12, 2025 · 06:00 EST
Started

This maintenance is now starting as planned.

January 12, 2025 · 03:00 EST
Resolved

This maintenance has been concluded as planned.

January 4, 2025 · 06:00 EST
Started

This maintenance is now starting as planned.

January 4, 2025 · 03:00 EST
Scheduled

ℹ️ NCentral New Update

We will update our NCentral server to the latest version 2024.6

User Action Required

  • No

For further information or assistance, please contact the IT Support team.

December 31, 2024 · 15:25 EST

← Back